Log in issues
Incident Report for finsit
Resolved
The previous technical problem has been resolved, finsit is available again.
Posted May 19, 2022 - 16:00 CEST
Investigating
We are currently experiencing technical problems which make certain applications inaccessible. Every effort is being made to resolve the situation as soon as possible. We apologise for any inconvenience this may cause.
Posted May 19, 2022 - 13:43 CEST
This incident affected: Finsit site.