Log in issues

Incident Report for finsit

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 10:36 CET

Identified

Finsit customers may experience login issues. The problem originates with Cloudflare and affects our identity provider. Cloudflare has identified the issue and is working to resolve it.
Posted Dec 05, 2025 - 10:16 CET
This incident affected: Finsit site.