Log in issues

Incident Report for finsit

Resolved

This incident has been resolved.
Posted Mar 24, 2023 - 16:53 CET

Investigating

We are currently experiencing technical problems which make certain applications inaccessible. Every effort is being made to resolve the situation as soon as possible. We apologise for any inconvenience this may cause.
Posted Mar 24, 2023 - 16:33 CET
This incident affected: Finsit site.